Try the comming up open-release juniper on local machine

Hello,
I have tried to run the coming open-release juniper on my pc using devstack but it has occurred some errors. Can anyone help me to run it locally?

I followed the instruction from the docs: https://edx.readthedocs.io/projects/edx-installing-configuring-and-running/en/latest/installation/install_devstack.html

At the 4th and 5th steps I used commands:
git checkout open-release/juniper.rc1
export OPENEDX_RELEASE=juniper.rc1

It had some errors after I run the command make pull`:

Pulling firefox (edxops/firefox:juniper.rc1)...
ERROR: manifest for edxops/firefox:juniper.rc1 not found: manifest unknown: manifest unknown
make: *** [Makefile:109: dev.up] Error 1

I have double checked on docker hub and found that there are no docker images for juniper.rc1 tag.

Thank you.

I think you’ll have better luck setting things up with the master devstack and then just switching to the juniper.rc1 branch. What I mean by that is: Set up the master devstack which will use the latest releases for each repository, and then check out the juniper branches for the repos.

I don’t think even the main edxapp has as docker image for pre-releases.

1 Like